Day: July 25, 2003

We’re working on getting TrackBack for Radio out the door, and have run into a problem. All the pieces seem to be working, except we haven’t been able to get Radio to register incoming TrackBack pings from a MovableType site.

This seems strange, since Manila is able to receive pings from MT just fine, and Radio is using basically the same code, but for some reason we’re getting different results.

When I try to ping my Radio site from my MT test site, I get an error saying that the ping failed, and to check the MT Activity Log, and while I see an error in the log, I don’t understand what it means. Here’s the error:

Ping ‘http://jake.userland.com/2003/07/24.html#a844’ failed: HTTP error: 500 Can’t locate HTML/HeadParser.pm in @INC (@INC contains: /var/www/cgi-bin/extlib /var/www/cgi-bin/lib /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl .)

Any help from MT/TrackBack-savvy people would be much appreciated. Please send an email or leave a comment on this post if you have any ideas.

Thanks!

Jake's Radio 'Blog

Comments closed

Jake's Radio 'Blog

Comments closed

We just released a pair of changes for Manila, which improve performance when updating a Manila site’s home page. Dave had found that pinging Weblogs.Com was taking a long time. The changes just released make Manila send the pings to Weblogs.Com in a separate thread instead of waiting for a response.

To get the changes, update Manila.root.

Jake's Radio 'Blog

Comments closed